Recipe Design Wizard™

The Recipe Design Wizard Plug-In for Adobe InDesign (cs, cs2, cs3 and cs4) and InCopy (cs, cs2, cs3 and cs4) for Mac and Windows
enables you to bring your recipes into the twenty first century with a layout that is attractive and significantly easier to use than traditional
recipes. The Recipe Design Wizard Plug-In effortlessly accomodates changes to the list of ingredients and the associated instructions by
automatically reflowing the recipe and resizing the adornments (curly braces) as changes are made to either the layout or the content.

Quick Start Guide
•

Quit InDesign if it is running. Copy the Recipe Design Wizard Plug-In into your Adobe InDesign CS Plug-Ins folder.

•

Go to http://www.wiskit.com/indesign to purchase a license and/or activate your copy of the Recipe Design Wizard Plug-In.

•
•
•
•
•
•

•
•
•
•
•

Customize the Keyboard Shortcuts, as described on the next page. On Windows, this is required if you want to use control-tab.
For InDesign cs2, cs3 or cs4, drag one of the Recipe Snippets into your document each time you are ready to create a new recipe.

For InDesign cs (or cs2, cs3 or cs4, if desired), copy the Recipe Templates to your Documents folder and Double Click one to open
(you may be unable to open the originals). Select the Sample Recipe, Copy, and Paste each time you are ready to create a new recipe.
Select the Text Tool, and select the text in the first table cell.

To create a correctly typeset fraction (e.g. 1/2) at any time, type option-shift-F 1/2 option-shift-f (Mac) or SHIFT-ALT-F 1/2
shift-alt-f (Windows). To switch from one form (e.g. 1/2) to the other (e.g. 1/2), select the desired text, and type option-shift-f
(Mac) or shift-alt-f (Windows).

Enter the quantity (e.g. ½) for the first ingredient, press Option-Tab (Mac) or CONTROL-Tab (Windows) to move to the next field,
enter the units (e.g. cup), press Option-Tab (Mac) or CONTROL-Tab (Windows) to move to the next field, and enter the ingredient. If
there are no units (e.g. 8 apples), press Option-Tab (Mac) or CONTROL-Tab (Windows) twice to skip the units field and move directly
from the quantity field to the ingredient field.
If there are additional ingredients, press Return, and repeat the previous step for the next ingredient.

Press Tab twice to move to the final table cell in the row, and enter the instructions. (You can use SHIFT-TAB to move back to the
previous table cell.)

If either the ingredients or the instructions require more than one line, the Recipe Design Wizard will automatically insert the curly
braces of the appropriate height, and will automatically adjust the height as you edit the recipe.
If there are additional ingredients and instructions, press Tab to add a row to the table, and repeat the preceeding steps.
Use Save As... to save the resulting document.

Hints for Formatting Recipes
•

•

One of the most common errors in measuring ingredients is to confuse teaspoons and tablespoons. To reduce confusion, we therefore
recommend the use of the standard abbreviations tsp and TBSP. Readers have told us that the use of all caps or all small caps for TBSP
emphasizes the difference between tsp and TBSP. To create small caps at any time, type option-shift-c tbsp option-shift-c (Mac)
or SHIFT-ALT-c tbsp shift-alt-c (Windows). To switch from one form (e.g. tbsp) to the other (e.g. tbsp), select the desired text, and
type option-shift-c (Mac) or shift-alt-c (Windows).
We often provide background information about the recipe between the title and the table, and we often place cooking and serving
instructions below the table, to produce a more balanced appearance.

Apple Crisp

8		

granny smith apples

Peel, core, and slice.

½
¼
½
¼
2

cup
tsp
tsp
tsp
tsp

granulated sugar
ground cloves
ground cinnamon
ground nutmeg
lemon juice

Add to apples and mix. Pour into a buttered
9 by 13 inch baking dish.

½
¾
6
⅛

cup
cup

tsp

granulated sugar
unbleached white flour
butter
salt

Blend until crumbly.

¼

cup

chopped pecans

Add to flour mixture and sprinkle over apples.

Preheat oven to 350ºF. Bake for 45 minutes or until the apples are tender and the crust is brown.

Customizing the Keyboard Shortcuts
•

It is strongly recommended that you install the Recipe Design Wizard.indk Keyboard Shortcuts into the InDesign Shortcut Sets folder
in the Presets folder in InDesign and choose this as the Shortcut Set using the Edit > Keyboard Shortcuts... menu, or manually define
the following Shortcuts using the Edit > Keyboard Shortcuts... menu. The Quick Start Guide and the Hints for Formatting Recipes on
the previous page assume that these Shortcuts are installed. Note that option-tab on the Mac inserts the tab character in a table cell,
so no shortcut definition for Insert Special Character: Other: Tab is required on the Mac.

Product Area

Command

Context

Mac Shortcut

Windows Shortcut

Panel Menus

Character: OpenType: Fractions

Default

Opt+Shift+F

Shift+Alt+F

Panel Menus
Type Menu

Character: OpenType: All Small Caps
Insert Special Character: Other: Tab

Default
Default

Opt+Shift+C

Shift+Alt+C
Ctrl+Tab

Customizing the Recipe Template
•

Recipe Templates and (for InDesign cs2, cs3 and cs4) Snippets are supplied for three paper sizes, as detailed in the following table.
You can use one of the supplied templates or snippets, or begin with one of these, and customize it to suit your requirements.
File Name

Recipe Template Standard

Recipe Template Medium

Recipe Template Small

Margins

0.75 in

0.5 in

0.5 in

Third Column

Second Column

First Column

Format

Paper Size

•
•

8½ x 11 in (Letter Size)

6 x 9 in

5 x 8 in

Font

Adobe Caslon Pro

Adobe Caslon Pro

Adobe Caslon Pro

Font Size

12 pt

10 pt

9 pt

Leading

14.4 pt

12 pt

10.8 pt

Width

248 pt

176 pt

140 pt

Left Indent

72 pt

60 pt

54 pt

First Line Left Indent

-72 pt

-60 pt

-54 pt

First Tab

22 pt

18 pt

16 pt

Second Tab

72 pt

60 pt

54 pt

Top Inset

7 pt

5 pt

5 pt

Bottom Inset

7 pt

5 pt

5 pt

Left Inset

4.5 pt

4.5 pt

4.5 pt

Right Inset

9 pt

9 pt

9 pt

Width

7.5 pt

6 pt

6 pt

Bottom Inset

7 pt

5 pt

5 pt

Top Inset

Left Inset

Right Inset
Width

Top Inset

Bottom Inset
Left Inset

Right Inset

7 pt
0 pt
0 pt

248 pt
7 pt
7 pt
9 pt
0 pt

5 pt
0 pt
0 pt

176 pt
5 pt
5 pt
9 pt
0 pt

5 pt
0 pt
0 pt

140 pt
5 pt
5 pt
9 pt
0 pt

We strongly suggest that you choose or customize a suitable template or snippet before formatting a significant number of recipes,
since there is no automatic mechanism to reformat multiple recipes for a new paper size after entering them. Note that copying and
pasting text preserves the original Font Size, Leading, and Tabs, but not Column Widths or Insets.

Since recipes make heavy use of fractions, we strongly suggest that you use an Open Type Pro font, which includes built in fractions.
Adobe generously supplies three suitable Open Type Pro fonts with InDesign cs: Adobe Caslon Pro, Adobe Garamond Pro, and
Adobe Jenson Pro. Many other Open Type Pro fonts are available for purchase.

Customizing the Recipe Template (Continued)
•
•

•
•
•
•

•

To check whether typeset fractions (e.g. 1/2) or small caps are available in a particular font, select any text in that font, then view the
OpenType Menu of the Character Palette Menu. If the [Fractions] or [All Small Caps] menu items are in square brackets, it indicates
that fractions or small caps are not available in the current font. For more information, refer to the InDesign User Guide.

We provide one row in our templates; extra rows can be inserted anywhere in the table at any time using the Insert Rows... function in
the Table Menu. Extra rows can easily be added to the end of the table by pressing the tab key with the insertion point in the last row
of the table. If the table spans multiple pages, Copy and Paste the first row of the table (which contains the adornment) into one of the
rows on the subsequent page to ensure that the adornments (curly braces) appear on each page containing a portion of the table.
The first cell in each row of the table contains the ingredients. Tabs are used to separate these cells into three fields. The placement of
the tabs has been chosen to allow the first two fields of most or all ingredients to fit on a single line.
Choose Vertical Justification: Align Center as a Cell Option for all cells in the first and third columns of the table.

The center cell in the first row of the table contains an embedded Text Frame with a width of 3 pts and a height of 4.5 pts. Recipe
Design Wizard[US]... has been selected from the Kitchen Wisdom Publishing submenu of the Plug-Ins menu to attach an Adornment
to the embedded Text Frame, with an Orientation of Left and the Table Cell and Entire Column attributes checked.

The Adornment (curly brace) is drawn only if the height of the table cell (excluding the Top and Bottom Insets) is greater than or
equal to 2.5 times the width of the table cell (including the Left and Right Insets). Therefore, it may be necessary to adjust the width
of the second column when adjusting the font size, to ensure that the Adornment becomes visible when a second line of text is added
(and is hidden when only a single line of text is present).
Use Save As... from the File menu and select Format: InDesign cs template to save a template rather than a document. Using
InDesign cs2, cs3 and cs4, an alternative is to drag the text frame containing the recipe template to the desktop, to create a Snippet.

Plug-In Menu

•
•
•
•

The Recipe Design Wizard Plug-In menu can be used to add an adornment to any Text or Graphic Frame. While the primary purpose
of this Plug-In is for formatting recipes, other uses are left to the reader’s imagination.
Four Orientations are available from the Plug-In menu: Top, Left, Bottom, or Right.

Fixed Width forces a width of 7.5 points. If this option is not checked, the width and height of the Adornment are determined by the
width and height of the Text or Graphic Frame. Note that the Adornment is drawn only if the height is greater than or equal to 2.5
times the width.
The Table Cell option causes the Adornment to take on the dimensions of the table cell (if any) containing the Frame. Note that the
Adornment is inset by the Top and Bottom Inset of the table cell, but not by the Left and Right Inset.

History of the Recipe Design Wizard

From the time he began cooking, Herb Weiner, the developer of the Recipe Design Wizard Plug-In, has been frustrated by the inconvenient
format used for recipes in traditional cookbooks.

Herb developed his unique new recipe format in 1981 as a student and self-appointed note taker for a group of friends and coworkers taking
Mexican cooking classes in the evening. The format allowed Herb to quickly and accurately record the ingredients and instructions for
preparing them as groups of students simultaneously prepared three or four different dishes under the direction of a wonderful chef whose
only record of her recipes was in her head. Because both the ingredients and the instructions for preparing them were organized sequentially
and grouped logically in the notes, the recipes were far easier to prepare, even in handwritten form, than recipes from traditional cookbooks.
Herb used primitive software to format the recipes for distribution to the other students. The collection of Recipes from these classes was
ultimately published as Beyond Tacos: Mexican Cuisine Copyright © 1984 by Regina Akers and Herb Weiner (ISBN 0-937383-00-7), and was
the first time that this format was used in a published cookbook.

In the twenty years since Beyond Tacos was published, Herb has sought a software solution for formatting recipes. The support for tables
first introduced by Microsoft Word offered capabilites significantly beyond anything else available at the time. Herb developed a technique
(http://www.wiskit.com/postscript/quicktips/recipes.pdf ) for formatting recipes by embedding PostScript directly into Microsoft Word
table cells on the Mac, but this technique is no longer supported in the latest version of Microsoft Word, nor was it ever supported by any
other page layout program.

In 2003, Herb began exploring the possibility of developing a Plug-In for Adobe InDesign, and realized that InDesign is a layout and
design software package based upon a modern, object-oriented architecture. It’s great to finally have a publishing solution that provides a
powerful development environment, allowing us to solve a 23 year old problem. We’re delighted that the release of the Recipe Design Wizard
Plug-In for Adobe InDesign finally brings Recipe publishing into the 21st century, and produces content that exceeds our customers’
expectations.
Recipe Design Wizard Version 1.0 for the Mac was completed in February, 2004. Based upon inquiries from Windows users, Herb
investigated the feasibility of supporting a Windows version, and was pleased to discover that Adobe’s InDesign architecture made this
feasible. Recipe Design Wizard Version 1.0 for Windows was completed in June, 2004. The User Interface is identical to the Mac version,
with the exception of a few Keyboard Shortcuts. The current versions are 1.1 for InDesign cs, 2.0 for cs2, 3.0 for cs3, and 4.0 for cs4.
Herb is anxious to hear your success stories using the Recipe Design Wizard Plug-In. You can email Herb at herbw@wiskit.com.

Contents of the Recipe Design Wizard package
•
•
•
•
•
•
•

The Recipe Design Wizard Plug-In. The same Plug-In works with either InDesign or InCopy, but each platform (Mac and Windows)
and each version of InDesign and InCopy (cs, cs2, cs3 and cs4) require a matching platform and version of the Plug-In.
Recipe Design Wizard.indk Keyboard Shortcuts.
These instructions in PDF Format.

Three Recipe Templates. For InDesign cs2, cs3 and cs4, three Recipe Snippets are also provided.
Apple Crisp Recipe in InDesign Format.

The Serial Number, if purchased, which is required to Activate the Plug-In. The Plug-In runs in Demo Mode if not Activated.
The Recipe Design Wizard Brochure in PDF Format. This brochure contains an additional recipe.

Frequently Asked Questions
•

What if I open a recipe or a recipe template without the Recipe Design Wizard Plug-In? What if I make changes and save it?

•

What is the Activation Process?

•

If you open a recipe, recipe template, or recipe snippet without the Recipe Design Wizard Plug-In, InDesign will warn you, and ask
you whether you want to open the document. If you proceed, the adornments (curly braces) will not display or print. If you save the
document, some or all of the adornments may be reset. We strongly recommend that you download and install the Recipe Design
Wizard Plug-In prior to making any changes or saving any document that was created using the Recipe Design Wizard Plug-In. You
are not required to purchase a license or activate the Plug-In in order to use it; however, the adornments (curly braces) will not print
unless the Plug-In is Activated.
The Recipe Design Wizard Plug-In operates in Demo Mode until it is Activated. In Demo Mode, the Plug-In is fully functional, except
that the adornments (curly braces) will not print and will not be exported to PDF or PostScript files. Activation can be completed at
http://www.wiskit.com/indesign, and requires the Serial Number that you receive when you purchase a license, and the Registration
Code that Recipe Design Wizard displays in the About box. Refer to http://www.wiskit.com/indesign for more information.
Am I permitted to install the Recipe Design Wizard Plug-In on multiple computers? Is it OK to give the Recipe Design Wizard
Plug-In to my service bureau, so that they can print my document?

You may install the Recipe Design Wizard Plug-In on as many computers as you wish, but you are allowed to Activate only those
copies for which you have purchased licenses. The remaining (unactivated) copies operate in Demo Mode. See the previous question.
•

•

•

You may freely copy, modify, distribute, and/or sell the templates or snippets and any documents you derive from them.
Why is there a small blue Frame (rectangle) in the top row of the second column of the table?

The Adornment (curly braces) must be associated with a Page Item (a Text or Graphic Frame). Adobe does not currently provide a
mechanism to associate an Adornment with a table cell. We therefore insert a Text Frame (the small rectangle) into the top table cell
(of each page) in each column that requires an Adornment.
Is the Recipe Design Wizard available for Quark XPress?

No. Adobe makes their InDesign Software Development Kit available at no charge, and then offers reasonably priced developer
programs for developers that require additional support. Quark, on the other hand, charges a license fee for the use of their Quark
XTensions Developer Kit. We don’t know whether it’s possible to provide the function of the Recipe Design Wizard as a Quark
XTension, and we don’t intend to pay Quark’s steep admission fee just to find out.
What about Trademarks?

Only a lawyer would ask that. Adobe, InDesign, and InCopy are trademarks of Adobe. Apple and Mac are trademarks of Apple.
Quark, XPress, and XTension are trademarks of Quark. Microsoft, Windows, and Word are trademarks of Microsoft. And Recipe
Design Wizard is a trademark of Kitchen Wisdom.

Kitchen Wisdom publishes cookbooks and gourmet software, and
provides software consulting and custom software development
services for the Mac and Unix. Kitchen Wisdom’s Internet address
wiskit.com uses the first three letters of KITchen and the first three
letters of WISdom.
Kitchen Wisdom Publishing
4647 SE 33rd Avenue
Portland, Oregon 97202
(503) 771-1400 • (503) 771-1401 (FAX)
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